Register

Having problems with Ventrilo

All the non-WOW stuff goes here.
Posts: 14
Joined: Fri Sep 30, 2011 10:05 am

Having problems with Ventrilo

Postby Aun » Wed Oct 05, 2011 12:25 pm

I have been playing WoW for a while but have only recently started using Ventrilo. I orginally started using it on a diffrent computer then what I am using now and it seemed to work fine. I was so happy when I got my hands on a friends headset and was finally able to chat in vent, only to find that, when I switch computers, I was no longer able to talk. Every time I log into vent now, regardless of if I am using a headset with a microphone, I get this warning:
Unable to activate DirectSound for selected device.
DirectSoundCaptureCreate failed. HR=DSERR_NODRIVER. No sound driver is available for use
Even with this warning I can still clearly listen to other people in vent. I have tried to google the problem and have only succeeded in finding more people who are in the same boat as I am.

Posts: 29
Joined: Thu Sep 08, 2011 11:21 am

Re: Having problems with Ventrilo

Postby Druidohorde » Wed Oct 05, 2011 12:44 pm

basically the sound driver you have setup under options isn't working, or can't find the device its trying to work with.

Since you can still hear, its likely your microphone? Can you speak back?

Just go to options on the right, and just select a different source other than DirectSound.

I get the same error when i unplug my headset from the computer.. I just reselect the headset, and it works again.

Posts: 14
Joined: Fri Sep 30, 2011 10:05 am

Re: Having problems with Ventrilo

Postby Aun » Fri Oct 07, 2011 6:50 pm

ok, so, I can clearly hear other people in vent, but I cannot speak. I was messing around with some settings, (which, as far as I know, were the same setting I had on the other computer which I could talk on and I didn't mess with anything on there so most of the setting where default) and found that the problem was with my input device. When I unckecked the defaut setting, the error messageno longer came up, but I still wasnt able to speak, which was diffrent for when I unchecked the output device, which gave the ther error regardless. The default directsound device is the only device that shows up on my imput drop down.
I don't know if this helps but I still have no idea what to do, or even what to look for.

Posts: 29
Joined: Thu Sep 08, 2011 11:21 am

Re: Having problems with Ventrilo

Postby Druidohorde » Tue Oct 11, 2011 12:31 pm

Keep in mind, whenever you make a change... you need to log out of vent, and reopen it.

If you can hear, but cant' speak its definately your input device. If you use a headset, with a mic... and you can hear your hardware is likely fine. Change the input setting under options, log out, and log back in. Then test. Make sure your push to talk key is properly setup (should light up when you press it). Lastly, make sure your mute button on your mic isn't active.

Return to Off-Topic Discussion

Who is online

Users browsing this forum: No registered users and 1 guest